Motorola Moto G — [Tutorial] MOTO G - Fazendo Wi-Fi funcionar novamente XT1032/XT1033 - Wi-Fi não funciona

  • Respostas:110
  • AbertoStickySem resposta
  • Posts no fórum: 35

02/03/2014, 20:42:17 via Web

Bom pessoal, recentemente tive um problema no meu querido Moto G, após viver trocando de ROMs (todo dia :V), aconteceu que do nada, o meu Wi-Fi não funcionava mais, eu apertava no "botãozinho" pra ativar, e ele não ativava, meio que dava uma travada.
Então após passar vários dias pesquisando, achei a solução em um fórum espanhol (já não lembro mais qual o nome), e então após alguns dias, resolvi fazer esse tópico explicando como resolver.


Tutorial:

Antes de tudo, tenha a ROM "Nexus G+" instalada em seu aparelho (por incrível que pareça, ela é a única que funciona Wi-Fi).
Se não souber como instalar, veja aqui o tópico do membro Gildásio Zeth (créditos a ele), ou se quiser, veja no próprio XDA clicando aqui (créditos a xmattjus pela ROM)...





Após ter a ROM instalada, faça isso no seu celular: Menu > Configurar > Sobre o telefone > Status > Endereço MAC da rede Wi-Fi.

Você deve salvar esse endereço MAC em algum lugar, sei lá pega a caneta e escreve na mão :bashful: , e lembrando que o endereço é diferente de celular para celular...

Então após pegar o endereço MAC, volte para a Stock Rom 4.3 Jelly Bean, se não sabe como: Tutorial AndroidPIT (créditos a jefferson h. pelo tutorial).



Depois de instalar a Stock ROM 4.3, faça ROOT no aparelho, tutorial (créditos Gildásio Zeth)


Depois disso, baixe esse arquivo, nele você vai encontrar as ferramentas necessárias. Depois de fazer o download, você vai encontrar 2 aquivos, abra o arquivo "WCNSS_qcom_wlan_factory_nv.bin" usando o bloco de notas do windows. Depois de aberto, você devera substituir os números "00:00:00:00:00:00" pelo endereço MAC que você anotou.
APENAS SUBSTITUA O ENDEREÇO MAC, NÃO MEXA EM MAIS NADA BLZ ??!!!!, depois de substituir clique em salvar e pronto.






Após isso instale o apk que você baixou "Simple_Explorer_1.9.3.apk"

Ok estamos quase lá, após a instalação, pegue o arquivo WCNSS_qcom_wlan_factory_nv.bin que você salvou, e passe para a raiz do seu celular via USB, após isso abra o Simple Explorer instalado em seu aparelho, quando você abrir, estará na raiz do seu celular, e então aperte e segure em cima do arquivo WCNSS_qcom_wlan_factory_nv.bin, e clique em mover. Após isso navegue até a pasta persist do seu aparelho, para chegar até ela, clique 3x o botão voltar, depois que estiver na pasta persist, clique no ícone vermelho para mover, fica na parte inferior esquerda do Simple Explorer.





Pronto !!! Depois disso, basta reiniciar o aparelho e o Wi-Fi estará funcionando novamente, também funcionara em em qualquer rom que você instalar depois.

Se após reiniciar o Wi-Fi não funcionar, reinstale a rom.

E mais uma coisa importante, na minha opinião, o que causa esse problema, é quando você da /format persist no CWM, então não faça isso!!!


Bom pessoal, esse é o meu primeiro tópico aqui no fórum, se ficou muito confuso, ou desorganizado, peço desculpas, é só prestar atenção que vai dar certo, e se mesmo com esse tutorial não deu certo, não faço ideia do que seja, abrss... :P

— alterado em 02/03/2014, 20:59:09

Liliana Lorenzojorge carvalhoBruno Henrique

Responder
  • Posts no fórum: 35

02/03/2014, 21:42:17 via Web

Parabens pelo guia cara, na verdade ficou muito bom, e tambem colocou tutoriais em tudo que precisava.
Eu mesmo nao sabia voltar pra stock rom e nao sabia desse guia então só isso ja ajudou muito.
Quando eu tiver um moto g e por acaso der esse erro,(nao vai demorar muito)vou ter um ótimo guia em portugues pra me ajudar.

vlw

Responder
  • Posts no fórum: 35

02/03/2014, 21:54:16 via Web

Alan Willian
Parabens pelo guia cara, na verdade ficou muito bom, e tambem colocou tutoriais em tudo que precisava.
Eu mesmo nao sabia voltar pra stock rom e nao sabia desse guia então só isso ja ajudou muito.
Quando eu tiver um moto g e por acaso der esse erro,(nao vai demorar muito)vou ter um ótimo guia em portugues pra me ajudar.

vlw
Fico feliz que você tenha gostado :grin: , qualquer coisa tamo ae.

Responder
  • Posts no fórum: 35

03/03/2014, 03:08:14 via Web

João Lucas Xavier Gonçalves
Cara, parabéns, depois de muitas tentativas enfim consegui fazer o wifi funcionar...
Nossa, quem bom velho, mais você disse que não tinha dado certo, tinha feito algo errado ? :D

Responder
  • Posts no fórum: 1

16/05/2014, 07:33:09 via Web

MUUUUUUUUUUIIIIIITO SHOW , realmente o q eu estava procurando ^_^ , ja havia reinstalado a rom stock varias vezes e nada do meu WIFI voltar a funcionar , mas esse seu tutorial resolveu meu problema , muito bem explicado.(Realmente deve ser a formatação do /format persist q causa isso^^ , tentei fazer overcloack e o moto g não ligava mais ai sai formatando tudo no CWM kkk mexi onde nao devia kkk
Valeu Abrass parabens pelo post.:D

— alterado em 16/05/2014, 07:35:42

Responder
  • Posts no fórum: 2

29/06/2014, 19:16:08 via Web

Preciso do link tbm. o que está postado aqui esta quebrado.. mero amigo caso encontre poste aqui .. irei fazer o mesmo se encontrar nessa minha busca interminavel. abraços = /

Paulo Henrique

Responder
  • Posts no fórum: 3

30/06/2014, 17:13:29 via Web

O link está quebrado, poderia me passar outro por favor?

O meu endereço MAC tem "Não disponivel"

— alterado em 30/06/2014, 17:45:37

Responder
  • Posts no fórum: 78

05/07/2014, 13:19:35 via Web

Bem, o titulo do tópico só resume meu problema. Desbloqueei o bootloader do meu Moto G XT1032, e já fui direto pra GPE, testei todas as Roms que gostei: Cyanogenmod, CrDroid, Nexus 5 Experience e Paranoid, mas voltei pra GPE.
Notei que ela não tem suporte a OTG, no meu caso eu uso bastante, então resolvi voltar à rom stock da Motorola.
Quando voltei à rom stock 4.4.2 baixei a atualização pra 4.4.3 mas deu erro na instalação, pensei "deve ser pelo bootloader desbloqueado", tentei várias vezes e formas de bloquear o bootloader, mas não consegui, resolvi, então dar um "Wipe Completo no sistema", instalei a GPE mais uma vez e coloquei o CWM, dei wipe data, wipe cache e wipe dalvik e fui até em "mounts and storage" (acho que é assim) e dei TODOS OS WIPES: Wipe system, wipe data, wipe tudo!, pensei "vou deixar tudo limpo e reinstalar a stock".
Bem, instalou, porém agora o WiFi não funciona, voltei pra GPE, instalei stock...nada! Tenho a impressão de ter apagado algum arquivo ou driver necessário pro funcionamento do WiFi porque ele nem chega a ativar.
Será que existe algo que eu mesmo possa fazer? Tipo, botar outra rom ou algum outro procedimento? Estou pensando em mandar pra assistência, mas SE eles puderem resolver, vão me cobrar um valor muito alto!
Procedimentos que tentei:
- Instalei a GPE de novo;
- Instalei Stock e resetei;
- Tentei Downgrade pra 4.3 (Não deu certo).

P.S.: Ainda continuo com o Bootloader desbloqueado.
P.S.2: Acabei de entrar em contato com a Motorola, eles não podem fazer nada a respeito, peguei o telefone da autorizada, falei com eles, disseram que é defeito na placa, 450,00 pra arrumar. o.O Não acredito que seja isso, creio que eu devo ter apagado o arquivo ou driver do Wifi.

— alterado em 05/07/2014, 14:19:36

Responder
  • Posts no fórum: 2 056

05/07/2014, 14:47:45 via App

Tem um tutorial aqui no fórum não tem passo pq tô pelo App. Mas procure ai que tem uma forma de estar recuperando... primeira vez que vejo você postando kkkkk

Estou aqui para ajudar, duvidas só perguntar

Responder
  • Posts no fórum: 78

05/07/2014, 15:15:05 via Web

Ciro F.

Tem um tutorial aqui no fórum não tem passo pq tô pelo App. Mas procure ai que tem uma forma de estar recuperando... primeira vez que vejo você postando kkkkk

Pois é Ciro, é a primeira vez mesmo. Eu já olhei vários tutoriais aqui, nenhum funcionou. Vou tentar refazer tudo outra vez com mais calma, embora eu ainda ache que seja algo fácil de resolver, dá muito trabalho!

Responder
Conta desativada
  • Posts no fórum: 12 371

05/07/2014, 15:47:46 via App

olá e só instalar a ROM pelo mfastboot, manualmente sem script, como ta nos tutoriais meu e do Gildásio, que vai resolver, esse bug se da quando tenta só recolocar o kernel, tem que reinstalar a ROM toda item por item, e fazer os erase no final

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

Eduardo G.

Responder
  • Posts no fórum: 78

05/07/2014, 16:15:52 via Web

jefferson h.

olá e só instalar a ROM pelo mfastboot, manualmente sem script, como ta nos tutoriais meu e do Gildásio, que vai resolver, esse bug se da quando tenta só recolocar o kernel, tem que reinstalar a ROM toda item por item, e fazer os erase no final

Jefferson, obrigado. Eu usei o script, deve ser por isso. Poderia deixar um link do seu tutorial pra eu ter certeza de qual fazer?

Responder
  • Posts no fórum: 78

05/07/2014, 20:54:05 via Web

Eduardo Garcia

Não consegui! Fiz como descrito no tutorial, o WiFi continua sem funcionar! E agora?

Consegui arrumar, usei um post daqui e vários do XDA e de outros lugares, em breve montarei um tutorial. Obrigado a todos que me ajudaram!(cool)

Responder
  • Posts no fórum: 64

05/07/2014, 21:22:52 via App

Eduardo Garcia

Eduardo Garcia

Não consegui! Fiz como descrito no tutorial, o WiFi continua sem funcionar! E agora?

Consegui arrumar, usei um post daqui e vários do XDA e de outros lugares, em breve montarei um tutorial. Obrigado a todos que me ajudaram!(cool)

o meu deu o mesmo problema do WiFi, quero saber como tu resolveu?

Responder
  • Posts no fórum: 78

05/07/2014, 21:41:17 via Web

maria

Eduardo Garcia

Eduardo Garcia

Não consegui! Fiz como descrito no tutorial, o WiFi continua sem funcionar! E agora?

Consegui arrumar, usei um post daqui e vários do XDA e de outros lugares, em breve montarei um tutorial. Obrigado a todos que me ajudaram!(cool)

o meu deu o mesmo problema do WiFi, quero saber como tu resolveu?

É bem simples, você coloca a rom stock, baixa dois arquivos: um gerenciador de arquivos pra root e outro pra colocar no sistema. Coloca ele lá e pronto, reinicia.
Estou tentando bloquear o bootloader agora, sem sucesso.

Responder
  • Posts no fórum: 4

12/07/2014, 01:07:47 via Web

Eduardo Garcia

Hei Felipe!

Olá Eduardo,boa noite. Li em um comentário teu ,que vc conseguiu resolver o problema do wifi,e eu estou quebrando a cabeça aqui sem solução,se vc puder me ajudar enviando ou disponibilizando os arquivos ,eu agradeceria muito.

Obrigado ,Nelson

Responder
  • Posts no fórum: 5

12/07/2014, 03:36:12 via Web

E ae blz.. Eu tive o MSM problema, eu consegui resolver usando o Faux kernel, mas ele é para ROM stock

Responder
  • Posts no fórum: 4

12/07/2014, 21:56:54 via Web

Olá,boa tarde ,agradeço aos dois por estarem me ajudando,sou novo na questão andróid ,estou aguardando,obrigado.

Responder
  • Posts no fórum: 2

22/07/2014, 04:48:59 via Web

Por Favor Por Favor Alguem Me Passa a Rom Nexus G+ Ja Preocurei Em Diversos Site Ate Em Site Japones Pra Ter Ideia Youtube e Nada Todos os Site Que Entro Aparece o Mesmo Link Mas Esse Link Estar Off Nao Ta Funfando Comprei o Moto G Num Tem Nem 2 Semanas Ja Estalei Diversas Roms Perdi a Garantia Estou Sem Wifi Por Favor Alguem Faz Um Video No Youtube Como Fazer Wifi Voltar a Funcionar ou Posta Os Links Que Funcione Por Favor Por Favor Me ajude So Tem Essa Maneira de Resolver? Eu Imploro Nem Terminei de Pagar Aguardando Resposta......

Responder
  • Posts no fórum: 3

22/07/2014, 18:08:34 via Web

não sei mais oque fazer tbm , ja tentei de tudo , poxa quem ter a solução da uma ajuda aq ,ficar sem wifi não da vei , se possivel ajudem aq desde ja obrigado

Responder
  • Posts no fórum: 6

23/07/2014, 03:29:20 via Web

Eduardo Garcia

Eduardo Garcia

Não consegui! Fiz como descrito no tutorial, o WiFi continua sem funcionar! E agora?

Consegui arrumar, usei um post daqui e vários do XDA e de outros lugares, em breve montarei um tutorial. Obrigado a todos que me ajudaram!(cool)

Cara pelo amor de de Deus tbm to com o mesmo problema a rom nexus foi descontinuada nao tem mais pra download em lugar nenhum meu cel tah na 4.3 jelly bean e nao da sinal de wifi de jeito nenhum...me ajuda ai cara por favor...não sei mais o q q eu faço!!:(

Responder
  • Posts no fórum: 638

23/07/2014, 13:15:07 via Web

Cara pelo amor de de Deus tbm to com o mesmo problema a rom nexus foi descontinuada nao tem mais pra download em lugar nenhum meu cel tah na 4.3 jelly bean e nao da sinal de wifi de jeito nenhum...me ajuda ai cara por favor...não sei mais o q q eu faço!!:(

Já tentou instalar a GPE manualmente pra ver se resolve?

A pressa é inimiga da perfeição e concubina da imperfeição... Ômega tester.

Responder
  • Posts no fórum: 6

23/07/2014, 21:05:33 via Web

JAH SIM...E NADA VELHO...(MAC ADRESS NAO DISPONIVEL) COMO RECUPERO O ENDEREÇO DE MAC SEM A ROM NEXUS G+??TO PRECISANDO URGENTE...NAO SEI MAIS O Q FAZER!!!JAH TENTEI UM TANTO DE ROMS E NADA

Responder
  • Posts no fórum: 7

25/07/2014, 00:37:38 via App

amigo veja como eu fiz para recuperar o meu WiFi morto ,apos ler vários tutorias consegui monta um pro moto g , não precisa de ROM especifica não basta apenas tem uma ROM roteada pode ser a retail da motorola ou qualquer outra e ter um explorador de arquivos no meu caso usei o root explore ,bem vamos lá abra o root explore e clique nas seguintes pastas : etc/firmware/wlan/ prima/ dai clique e segure uns segundo clicado e escolha a opção abrir com editor de texto a pasta WCNSS_qcom_cfg.ini. , após abrir procure pelos comandos nas linhas INTF0MACADDRESS= o endereço que aparecer ao lado é seu endereço mac ,após anotar os endereços siga com o tutorial aqui apresentado no site vai usando eles que um deles vai da certo , no meu deu certinho WiFi funcionando novamente .

Responder
  • Posts no fórum: 1

25/07/2014, 05:12:46 via Web

Seguinte, tenho um Moto G XT1033 e estou tendo uma baita dor de cabeça.

Nao consigo acessar nada do google, nem play store, nem navegar na internet e nem ao menos adicionar uma conta google ao meu dispositivo (quando tento diz que nao foi possivel estabelecer conexao confiavel). Vi uns tutoriais na net que me mandavam fazer root no celular para alterar o ip porem para fazê-lo sempre tinha que baixar algum aplicativo, o que, pra mim não é viável já que nao tenho acesso à play store (aparece o erro "Sem conexão" sendo que eu tenho wifi em casa).

Tentei baixar do PC pro celular e tambem nao consegui porque sempre tinha que baixar outro aplicativo pra fazer a instalaçao dos mesmos.

Já não sei o que fazer, estou desesperado pois tenho um celular que não posso desfrutar 100%, gostaria de saber se alguem pode me ajudar.

Grato.

Responder
  • Posts no fórum: 6

25/07/2014, 05:27:03 via Web

Cara fiz o que voce falow mais ainda nao ativa o wifi...descobrir 4 Macs do celular mais nenhum deu nao sei se to apagando algo a mais no bloco de notas mas continuo sem wi fi.....nao sei mais o q q eu faço velho......:'(

Responder
  • Posts no fórum: 7

25/07/2014, 11:40:51 via App

Nossa no meu deu certinho fazendo assim , mas notei uma coisa no meu bloco de notas quando digitei o código mac não coloquei 2 pontos (:)entre os dígitos do código como mostra no tutorial daqui e sim apenas 1 (.) Faz assim quando abrir o bloco de notas apaga tudo que tiver dentro ,depois digita o código mac todo em maiúsculo colocando ponto final após cada 2digito do código ,depois salva ,fecha o bloco de notas e depois abre novamente só pra ver se salvo certo ,depois coloca ele dentro da pasta persist .

Responder
Conta desativada
  • Posts no fórum: 12 371

28/07/2014, 03:07:48 via Web

por favor parem de escrever post com letras maiusculas, se insistirem os post serão simplesmente apagados.

Quando você for seguir um tutorial,primeiro leia atentamente o passo a passo,em seguida leia os relatos das duvidas e dificuldades que outros tiveram ao fazer o tutorial, assim você terá toda a confiança para prosseguir com o tutorial sem problemas.
Se alguém lhe ajudou, não esqueça de agradecer, clicando no icone de positivo,isso incentiva quem está aqui disposto a ajudar .

Responder
  • Posts no fórum: 2

14/08/2014, 23:27:53 via Web

o cara fazendo favor envia pra min o meu gmail e pedrobarbuglioneto999@gmail.com manda cara to precisando urgente

Responder
  • Posts no fórum: 20

15/08/2014, 05:13:13 via Web

Sidinei Galvan

Passa um e-mail teu que mando pra você .

Ficaria grato meu email é fno93@live.com ,obrigado

Responder
  • Posts no fórum: 1 197

15/08/2014, 11:06:48 via Web

Gente eu comecei a ter esse problema agora quando fui reinstalar a CM, reinstalei a gpe e depois coloquei a CM, na gpe o wifi funcionava so q na CM nao, alguem sabe oq devo fazer?

Modelo: Redmi 2 - HM 2LTE-BR
ROM: NXROM
Kernel: Stock
Xposed e Root

Modelo: Moto G 2014 XT1068
ROM: NXROM 10.0.1
Kernel: MonsterKernel V3
Xposed e Root

Responder
  • Posts no fórum: 2

16/08/2014, 14:00:29 via Web

por favor sidnei manda o arquivo manda nesse aqui o ve se da pra manda hj o e-mail e pedrobarbuglioneto888@hotmail.com to perecisando muito mesmo

Responder
  • Posts no fórum: 3

27/08/2014, 20:56:37 via Web

Entrem no XDA DEVELOPERS e vão no fórum do Moto G.
Vão em Android Development e procurem exatamente assim "MoTo G Stock ROM" e sejam felizes

Responder