Moto G7 Plus não executa nenhum comando adb ou fastboot

  • Respostas:2
  • AbertoNão stickySem resposta
  • Posts no fórum: 1

16/10/2019, 01:12:49 via Web

Boa noite
estava tentando instalar uma custom rom no meu Moto G7 Plus instalei o twrp 1x
fiz o wipe e tentei transferir a custom rom para o dispositivo por usb não estava dando reiniciei o aparelho e bootei novamente o twrp 3.3.1 ai o touch nao funcionava mas transferiu a rom , ai reiniciei novamente e bootei o twrp novamente e ainda nao funcionava o touch ai fui beber uma agua esfriar a cabeça e um momento depois fui tentar novamente na hora que mando o comando do fastboot boot recovery.img ele da "failed" mas dou fastboot devices ele reconhece o meu celular e sempre da esse "failed" tentando varias vezes consecutivas ele fica sending "boot.img" mas nunca finaliza alguem pode me ajudar esse problema poderia ser drivers?

Responder
  • Posts no fórum: 2

17/09/2020, 16:49:58 via Web

Depois de ficar alguns dias pesquisando e tentando, enfim consegui resolver. Acredito que várias pessoas passaram por isso e talvez tenham levado o aparelho a uma dessas lojas de celulares pra tentar resolver. Eu tive o retorno que só existia a possibilidade de 50% de resolver e dar certo e que mesmo se não desse certo teria de pagar. Bom vamos ao que interessa, como o tópico diz ao executar comandos fastboot sempre retornava "failed" ou travava. Achei que podia ser drivers corrompidos e tentei em outro computador do mesmo modelo e o erro continuava, então quase desistindo resolvi usar outro computador que eu julgo mais seguro, era um micro um pouco mais velho, mas com uma placa mãe asus, hardwares conhecidos e estáveis.
Pra minha surpresa usando exatamente o mesmo software ao executar os comandos rodaram todos sem dar erro. Executei novamente um fastboot getvar all e rodou completo sem travar e sem dar erro como dava antes. Então me animei fiz flash com uma ROM correta e o aparelho voltou a funcionar perfeitamente. Um alívio pra quem achou que tinha perdido o aparelho. Logo se estiver enfrentando esse mesmo problema usando ADB ( comando fastboot retornando failed com msg de erro diferentes a cada execução, ou começa a executar o comando e trava ) não desanime, tente encontrar uma máquina com hardwares mais confiáveis e tentar utilizar novamente o ADB. Acredito que existe alguma incompatibilidade de hardware que gera esse problema. Espero que esse tópico possa ajudar pessoas que como eu ficaram dias tentando achar solução e não encontravam nada na internet sobre isso. Ah, uma dica, quando for baixar uma ROM encontre a informação do modelo completo do aparelho, no meu caso era um moto z3 play XT1929-5 e acabei gravando de outro modelo porque não encontrei a informação XT1929-5 na ROM do site que baixei, tem sites bons que trazem essas informações e muito mais. Fiquem atentos. Abraço a todos.

útil?
Responder
Recomendado pelo NextPit